ZR3 bleed-off cooler weepholes venting H20

by Robert
(Alaska)

We have 3 ZR3 compressors and noticed on one of them, the bleed off cooler when unloaded will vent water out of the lower 2 of 4 "weep holes".


We have troubleshot the auto and manual discharge system for blockages, found the mechanical float system works correctly.

When manually dumping the system the water subsides for approximately 24 hrs.

The other units do not weep water.

Any direction would be appreciated.

Comments for ZR3 bleed-off cooler weepholes venting H20

Click here to add your own comments

Aug 09, 2018
Re: ZR3 bleed-off cooler
by: Robert

I would like to add some images but cannot figure out how. It is an instrument and plant air system.

The auto drain system is mechanical, it has a float with a valve similar to a toilet, when the float rises, the water collected is vented.

The other units have a steady drip from the vent line whereas this one seems to be venting from the before mentioned 'weep holes'

(To add photos to an existing post, start a new thread in this same forum, use the same title as the original post and write that the photos are for an existing post with the same title, and you can then upload up to four more photos. They will be moved here - Moderator)


Aug 08, 2018
zr3-bleedoff-cooler-weepholes-venting-h20
by: Doug in s.d.ca.

These are old, and not much on the web, so some pix might help.

Still, are we talking about an integrated refrigerated unit, or something separate?

Have you been able to compare the normal drain quantity to the suspect one? It sounds like perhaps it's not opening the auto-drain long enough, so if it's integrated, maybe a controller setting is wrong.

Please let us know when / if you find a solution.

Thanks.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.