Speedaire Compressor 3Z173 keeps cycling

by Steve Sleeper
(St. Louis, MO)

I have a Dayton Speedaire Ind. Compressor 3Z173 and no manual or parts catalog for it. The problem I have is after it starts and reaches max pressure it dumps pressure and then starts again and repeats this cycle until I kill power to it.


Is this an unloading valve problem?

Any info you could give me would be appreciated.

Comments for Speedaire Compressor 3Z173 keeps cycling

Click here to add your own comments

Jan 08, 2017
compressor loosing pressure
by: Jeff

It sounds like you have a air leak somewhere, I would mix a little of dishwater detergent with water and pour or spray it on all you mechanical joint. If the mechanical joint or joints leak it you will see show bubbles around the joints, if so disassemble the leak and apply Teflon tape to the joint and retighten the joint.
If it were the loading valve you would hear it pop and could hear the air leaking.
If there are no leaks found it could possible be your piston ring or rings are worn and should be replaced.

Jan 07, 2017
Speedaire compressor 3Z173 cycling
by: Bill

Could be an unloader problem, Steve. Have you checked to be sure the unloader works on this compressors?

You might also want to check out the tank check valve to be sure it's working.

See the pages on this site that explain what they are and what they do if you aren't sure.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Speedaire Compressor Issues.