Paasche D500SR Air Compressor won't build pressure

by Dalia
(Ontario)

Paasche D500SR Air Compressor

Paasche D500SR Air Compressor

I have the Paasche D500SR Air Compressor. First time trying to use it.


When turning the compressor on, the air runs.

When I add the piston and moisture trap portion, I run into problems. Initially, air was escaping, so I added the plumbers tape (as per the instruction manual). Then the compressor runs for a few seconds, and shut off. PSI never builds up on the gauge. If I release the pressure, the compressor will turn on again, then turns off again (repeat over and over). When pressing the airbrush, no air flow comes out (it doesn't trigger the compressor to turn on). I have no idea what I'm doing wrong. I've sealed all the air leaks. I tried turning the pressure gauge completely on low, and then on high. Nothing works.

Comments for Paasche D500SR Air Compressor won't build pressure

Click here to add your own comments

Jun 06, 2018
Paasche D500SR
by: Bill

"When I add the piston and moisture trap portion" has me a bit confused.

The moisture trap, also known as a compressed air filter on the Paasche D500SR contains both the filter and a regulator. No piston that I know of.

If, without the addition of the F/R (filter regulator) the compressor runs freely and air exits the F/R port, then it's got to be the F/R that is the problem.

Are you certain that you are installing the F/R with the flow arrow on the housing pointing away from the compressor?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Paasche air Brush Compressor Issue.