Compressor is on, runs for minutes, cuts off and smokes?

by kevin rodriguez
(plaquemine LA.)

Compressor is turned on and runs a few minutes then cuts off and some smoke comes out the air intake end of the unit.


Unit is a CompAir Kellogg
Hydrovane 128
8 bar

Comments for Compressor is on, runs for minutes, cuts off and smokes?

Click here to add your own comments

Apr 12, 2018
Hydrovane 128
by: Kevin rodriguez

Filter was changed a couple weeks ago after the problem started. The unit only runs about 2 min before cutting off. I will check the thermostat on the radiator to see if it is stuck. Radiator doesnt seem to get hot as it does not run long.

How would i check the electric thermostat in the control box.

How many ohms should it have if working correctly.

Apr 11, 2018
Compressor smokes
by: Doug in s.d.ca.

That suggests that the oil is overheating.

Have you checked the oil filter?

Is the radiator getting hot? If not then the the thermostat is probably bad, and/or the filter is clogged.

Apr 10, 2018
Response to Doug
by: Kevin Rodriguez

Doug, It makes air while its running. It cuts off after a few minutes like you hit the stop button to turn it off.
It is full of oil.
Right before it cuts off it starts smoking by the air intake end of the unit.
Kevin

Apr 10, 2018
Hydrovane 128 smokes
by: Doug in s.d.ca.

Does it make air?

Does it cut off like turned off, or does it slow down and then stop?

Does it have sufficient oil?


Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Hydrovane Air Compressor Issues.