Atlas Copco XAS450 JD7 no power to the panel, won't start

by Charlie
(Brantford, Ontario, Canada)

Hello, I have an Atlas Copco XAS450 JD7 tow behind compressor that i just received.


The battery is fully charged but i don't have any power to the panel.

There doesn't seem to be an isolation switch and all the connections seen to be good.

Any suggestions would be appreciated.

Comments for Atlas Copco XAS450 JD7 no power to the panel, won't start

Click here to add your own comments

Dec 07, 2018
Atlas Copco XAS450 JD7
by: Moderator

I believe the repeated question about "just received from where" by Doug is to determine how old this compressor is and if it is, perhaps, under some sort of warranty?

I am curious that you have not provided this info since it's now been asked twice? (Three times if you count this one)

Dec 07, 2018
Atlas Copco XAS450 JD7 compressor
by: Anonymous

Hi Doug, I have traced the wires and have power going to the panel and starter.

I was hoping that I didn't have to take the panel apart to check the breakers and connections.

I manage a wharehouse that is a distributor for Gardner Denver.

Dec 07, 2018
Just received from where?
by: Doug in s.d.ca.

You said "Hello, I have an Atlas Copco XAS450 JD7 tow behind compressor that i just received. "

I asked : From where?

And yes, clearly some power problem.

Have you tried tracing power to the controller?

Dec 06, 2018
Atlas Copco compressor
by: Charlie

Hi, yes it does not start. I believe that is because there is no power going to the panel that starts the compressor.

Dec 01, 2018
Atlas Copco XAS450 JD7 no start?
by: Doug in s.d.ca.

Just received from where?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Tow Behind Compressor Issues.