am40hc4v Regulator problem, need help

by Marty
(sonoma, ca)

Hi, I have a emglo twin stack am40hc4v compressor.


Leaking out of the 2 holes on the regulator, I found a repair kit and installed it correctly.

Still leaks out of the two holes.

When the compressor is turned on the pressure goes to max 40 psi on both gauges and keeps running.

When shut off the air bleeds off through the two regulator hole,

Thanks, Marty

Comments for am40hc4v Regulator problem, need help

Click here to add your own comments

Sep 16, 2018
am40hc4v Regulator
by: Doug in s.d.ca.

Thanks for the update...

Glad you got it sorted.

Sep 15, 2018
Regulator repair kit installed but still leaks
by: Anonymous

I discovered when installing the new regulator repair kit all plastic seat and plastic knob must be tighten with a screw driver and the knob with a wrench.

I thought tightening by hand would be fine but discovered that was the leak issue.

Sep 14, 2018
Regulator
by: Doug in s.d.ca.

Sounds like it could be in backward...

Can you turn it all the way down to off and get pressure?

BTW, you do have the drain valve closed, right?

Sep 13, 2018
am40hc4v Regulator problem
by: Bill

I suspect the first thing you should fix is the leaking tank check valve.

Once it no longer leaks, if your compressor is not building air properly, look on the troubleshooting page on this site for the page about that problem, and follow the checks.

Let us know what's what, would you Marty?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Emglo Air Compressor Issues.