xas 125 wont keep running

by don
(norfolk uk)

ive just bought a diesel xas125..it starts fine but shuts down after only a few minutes,it will restart again straight away but again will shut down....


when starting i have to hold the start button for up to 30 seconds until the red light goes out is this normal..

im sure its not overheating in either engine or compressor...

ive renewed diesel filter....so i would appreciate some type of elimination process..

another issue is an oil drip/leak from somewhere behind the turbo.. or it even looks like it could be coming from the head gasket..are these 4cylinder duetz prone to either..

many thanks Don

Comments for xas 125 wont keep running

Click here to add your own comments

Aug 30, 2016
reply to doug
by: don

yes fuel filter;

no to engine oil or compressor oil filters... but to be honest they look like new.

anyway after cleaning the switch and all other connectors on the back of the control panel i set it running and it went for around 30mins until i stopped it as it was getting late on a bank holiday monday evening...so i think fingers crossed ive cured that....

my concern now is the oil leak which is getting worse and of coarse if its head gasket will it mean at least a warped or cracked head..

its the 1011 engine with single head as opposed to the individual barrels and heads like on my other deutz compressors..and it looks like a cast head not aluminum,, can anyone confirm this and perhaps tell me what i can expect to find once i remove the head,,,should i leave it alone,,,are there any of these liquid fix its that might work in an air cooled engine??

regards Don

Aug 29, 2016
filter
by: Doug in s.d.ca

So, by diesel filter you mean fuel.
What about air and oil filters?

And the sound-runs sweet and then shuts down clean is what I wanted.

Sounds like the switch is a possible.

Let us know, please.

Aug 29, 2016
response to doug
by: don

hi Doug like i said diesel filter..
it will shut down whilst still in idle..
not sure what you mean by what does it sound like..
it runs sweet as a nut then just shuts down swift and clean..
however i now suspect the ignition switch or wiring as i sometimes detect a slight delay in the yellow light coming on and have noticed it sometimes shuts down as i close the canopy or go to press the make air button..this coupled with the need to on rare occasions having to short out the solenoid to get it spinning....incidentally it has a brand new starting motor..

Aug 28, 2016
filter
by: Doug in s.d.ca

Which one(s)? Fuel, air, oil...

What's it sound like when stops - and is it at idle by then or is it still loaded?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.