craftsman - Trying to get 100psi into bike tire

by Al
(medham, nj)

2 cylinder, single stage, 3 gal, 20 hp made by devebliss


output pressure into tire less than max tank pressure.

Trying to get 100psi into bike tire:

tank 100psi
regulator value set at max
tire psi after filling: 76 psi

lost 24 psi.

Thanks, Al

__________________
Bill says...

Al, if the tank gauge is reading 100 PSI, what is the gauge on your regulator showing? It is the pressure setting of the regulator that dictates the maximum pressure going to your tire.

My guess is that it's set for 76 PSI, or it is failing, and won't let a higher pressure through to inflate your tire.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Craftsman Compressor Issues.

Craftsman 12 gal. compressor leaking oil from cyliunder head bolts

by Mike B.
(Gillespie,IL)

My new 12 gal. compressor is leaking oil from all 4 head bolts. It may have approximately 3hrs running time. The bolts are tightened properly...but still is leaking. Should I just take them out & place a dab of Rite Stuff on the end of each bolt? It also leaks from 1 bolt on the plate near the oil level viewing window.

_________________________
Bill says...

Mike, sure, you can monkey with it and try to stop the leak.

What I would do, in your shoes, is take the darned thing back and get a new one.

If there is that much oil on top of the piston that it leaks out of the head bolts, then maybe the piston seals are shot as well.

Good luck.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Craftsman Compressor Issues.

wont build pressure

by jackson
(enid ok.)

i have a craftsman 3 gallon 1 horse compressor that builds to 30 psi and stays even though the compressor continues to run ive looked at the reed switches and piston rings and all looks normal it seems to be drawing in air not sure where to look next...
__________________
Jackson, good you checked what you did.

Look on the sitemap page under troubleshooting, and see the page about why air compressors run but don't build pressure for some tips.

After you have done so, and looked at those things, comment here with your findings if you wish.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Craftsman Compressor Issues.