GA45 not working. Unloading ok but loading not working.

by Khaled Bin Mahmud
(Dhaka,Bangladesh)

Screw type air compressor GA45 not working (Unloading ok but loading not working)


Our compressor setting 6.5(loading pressure) & 7.5 (unloading Pressure)but when reached 7.5 bar unloading mode work automatically but when reached 6.5 /below loading pressure mode not working .when we press UV to oil tank pipe then it go throw loading.we check solenoid & UV ok.Please explain actual problem.

Click here to read or post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

GA45 compressor display problem

by Ahmed
(Egypt)

we have Atlas Copco screw air compressor single stage oil flooded GA 45.

Our troubleshooting display suddenly turned off during the operation and compressor stopped.

Ideas?

Click here to read or post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

High Element Outlet on model GA45+

by Jonathan Reyes
(Claver, Surigao del Norte, Philippines)

Atlas Copco air compressor model GA45+.
We almost experience high element, then many times after reach the high temp. compressor suddenly stop.
We already inform Atlas Copco technician but still the problem occur.
We ask you knowledge or maybe you encounter the same problem.
What are the common causes of getting high element?
We are hopping for any advice.

Click here to read or post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.