brand new TC-20T - motor runs for a while, then sputters out.

by Michael
(Herndon, VA, USA)

Hi,


I just bought a TC-20T (the one with the 3-liter tank attached). I fired it up for the first time and the motor ran for 20-30 seconds, the pressure gauge read ~15psi, then the motor stopped running constantly and started sputtering every few seconds. I ran the airbrush until the gauge went back down to 0psi. But the motor never kicked back on. it just kept sputtering and eventually stopped altogether.

I shut it off for a while, then came back and tried again. same results.

If I run the motor without a hose/airbrush attached, then the motor is quieter and runs constantly, just blowing air into the room.

do I possibly have a bad regulator, or maybe the motor is bad?

which part of the system tells the motor when to start/stop? That seems to be where the problem lies.

note: the metal body of the pressure gauge was bent up a little bit out of the box. I bent it back down by hand. But the mechanism inside didn't seem to bend at all. just the casing.

thanks for your help,
-Mike

Comments for brand new TC-20T - motor runs for a while, then sputters out.

Click here to add your own comments

Apr 14, 2015
Compressor sputters
by: Bill

Could be a number of things, Mike, including you got a dud compressor.

Given that it is new, my advice is don't monkey with it, send it back and get a new one.

Bill

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Air Brush Air Compressor Issues.

TC-20 getting too hot

by jon
(hazlet nj)

My master TC-20 is getting to hot to touch then starts sputtering

Comments for TC-20 getting too hot

Click here to add your own comments

May 20, 2015
too hot
by: Doug in s.d.ca

Absent any changes in how or where you use it, if it's running more than it used to your piston rings are probably shot.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Air Brush Air Compressor Issues.

Werther MAC-A airbrush compressor gets hot on top

by Jim Kirkpatrick
(Tyler Texas)

Werther MAC-A airbrush compressor gets hot on top will not turn off

Werther MAC-A airbrush compressor seems to be getting very hot on top of small compressor. How long to for auto shut off to work? Thanks

Comments for Werther MAC-A airbrush compressor gets hot on top

Click here to add your own comments

Feb 01, 2015
Werther MAC-A airbrush compressor
by: Bill

What's the normal cut out pressure on this compressor, and when it's running, does the pressure get anywhere near that, or does it just run and not build pressure past a certain point.

If the latter, see the troubleshooting page on why air compressors run but don't build pressure.

If other, add a comment here with details please.

Bill

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Air Brush Air Compressor Issues.