Sullair compressor slipping belts with only 20 psi pressure

by Dave
(Ontario Canada)

older Sullair compressor

older Sullair compressor

older Sullair compressor
Sullair compressor belt closeup
Sullair compressor belt drive

Hello,


I recently purchased an older Sullair compressor. Not sure of the model number as it's no longer visible. It used to run on 150 hp electric but I converted it to run with a tractor PTO. I have 4 b v-belts driving it and as soon as I reach 20 psi the belts start slipping badly. The belts are already very tight but that's not helping. I have checked the air intake and there are no restrictions in it. What I am wondering about is whether I have too much or not enough oil or the wrong kind of oil in it. I am currently using just standard hydraulic oil in it but I don't know how much to put in. Any help would be much appreciated

Thanks
Dave

Comments for Sullair compressor slipping belts with only 20 psi pressure

Click here to add your own comments

Sep 06, 2015
More on belt drives
by: Doug in s.d.ca

Did some poking around, and find a couple of calculators out there that purport to give you a belt and pully selection based on HP and RPM.

Depending on your particulars, a four belt system could work, but would likely require either a 1:1 ratio and/or possibly an idler (to increase wrap on the pullies).

Google "v-belt HP" for a selection.

Please keep us posted on what you do.

Thanks and good luck.

Sep 06, 2015
belts
by: Doug in s.d.ca

Can't tell if it's feasible, but I think you need to put a direct drive coupler on this.

Sep 03, 2015
belts
by: Doug in s.d.ca

Sounds like the fix may be a bigger pully on the compressor end. Or some (more) direct-drive system.
Consider that an auto generator at 60Amps is only about one horsepower, so your pully with one belt would handle maybe 10HP, and the four around 40HP.

Really need a pic or four so someone (won't be me) can ID it.

Sep 03, 2015
Doug
by: Dave

Trying to run the compressor about 1000 rpm but can only get to about 400 before the belts start slipping. The belts are slipping on the compressor end as the pulley on the compressor is about 7 inch and the other pulley is about 13 inch. I have 60 hp on the PTO.

It is a screw compressor.

Sep 03, 2015
belts
by: Doug in s.d.ca

So, if the belts didn't slip, what's the RPM of the pump? How much power on the PTO? I'm guessing the slippage is at the pump end of the belts?

Is it piston or screw? We can't really speak to the lube w/o knowing at least that.

Maybe send some pix of the set-up and the pump?


Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Sullair Air Compressor Issues.