Sullair 125 dies if not using air

by Rod Gaugh
(Berger, Missouri)

Have an older Sullair 125. $ cylinder GM engine starts and runs well causing pressure to build quickly. As soon as pressure is up to 110 or so all ports must remain open to continue running. If you close air ports or stop using all the air produced it dies. Also, How do you change hydraulic fluid and what fluid to use. It appears to be a close system with no fill port or level check.

Comments for Sullair 125 dies if not using air

Click here to add your own comments

Jul 10, 2014
shutdown
by: Doug in s.d.ca

So it was the throttle sticking.

Thanks.

Jul 09, 2014
responding to Doug
by: Rod

Followed your advice.

I started it and monitored all the pressures closely with air valves open so it wouldn't die and allowed it to warm.

When all pressure were at normal I slowly closed off the air ports checking the throttle operation as I did.

I had previously lubricated and assured throttle operation so I just made sure it was responding as the air was being closed off.

I continually checked the air pressure in case it was building too high.

I completely closed off the last of the ports, totally expecting for the thing to die. I was surprised when it ran correctly.

Jul 07, 2014
Happy happy...
by: Doug in s.d.ca

Rod:

Glad it's working. Can you tell us about what you found, please?

Might help the next guy.

Jul 06, 2014
To Doug
by: Rod

Thank You For the help. Sometimes you can not see the forest for the trees. Just being told some simple things helped me to take my time and follow procedures. Got it working now. Thanks again.

Jun 25, 2014
dies at cutoff
by: Doug in s.d.ca

Can you get it to idle or at least slow down?
I'd try leaving ports open and run it for a few and see if you can then slowly close the ports, and get to idle.

Watch the throttle - does it move at all as you close the ports?

If it does, and dies, then I'd think the motor idle fuel path is not letting fuel in.

If throttle doesn't move, then you could be looking at either a leak in the control circuit, and/or inlet valve failure. (is yours the solenoid inlet control?)

Jun 24, 2014
Reply to Doug
by: Rod

I start engine and it starts running on high idle. Pressure builds with no change in engine rpm. With ports open air blows from pipes and engine stays running. soon as ports closed the engine just shuts down like gas would be shut off. I am assuming it is a pressure switch problem but don't know how to check or if I should look at some other issue.

Jun 16, 2014
dies?
by: Doug in s.d.ca

How?

Does it try to go to idle or keep running full-on and lug down to a stop?

If no idle, it may be stopping on a safety overpressure

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Sullair Air Compressor Issues.