Model 3.z 174 b loud noise coming from the pump

speedy and model 3.z 174 b 2 stage sounds like a loud noise


this is a hand-me-down compressor

I asked about clapping noise from the heads of the pump

bills up air smell hard to get past 120 psi and gets real hot from running so long to get up to that pressure

what do you think is wrong with it and is it worth fixing

what is this model still worth

I saw one on ebay for $300

somebody tried to convert a 220 to 110 and they broke the off an on switch I forgot what you call it but it's made by furnace and I got it running but I think it should be quieter than what it sounds
_________________
I can't hear your air compressor friend, but from what you've written, my first thought is you've blown a gasket inside, between the low and high pressure stages.

Do a search for your Model number and I suspect you'll find parts, or, look at the troubleshooting compressors list on the sitemap page for pages with more info.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Speedaire.

Release the grommet t change out on/off control box

how do i release the grommet and wire from the pressure switch box?
__________________
Well, not knowing the model of your Speedaire to try and have a look at the pressure switch on that compressor, typically, when I've had to release the grommet and wire from the pressure switch, I remove the pressure switch cover after unplugging the air compressor, if I have any concern about remembering the wiring setup I take a digital picture (the old memory is going, don't you know), I remove the supply side wires from the terminals inside the switch, and then, again typically, I pop to strain relief fitting out of the side of the pressure switch as I pull on the wires.

I hope this helps. I can only offer generalities when I cannot have a look at the actual model referred to in the compressor problem.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Speedaire.

model #4b242 speedaire motor overload trips out at 20 PSI

by Raymond Hurtado
(Warm springs Oregon)

I have a speedaire model #4b242 on a dry fire system, the trouble im having is the compressor will operate fine till it reaches 20lbs pressure then it will cycle off and on till the motor trips out,

i checked my line voltage its at 208v the motor is rated at 230 is this causing my issues,

i had the same issues with another compressor in the same place thought i had a bad one so i replaced it with a new one and still have the same issue. any ideas would be helpful

Comments for model #4b242 speedaire motor overload trips out at 20 PSI

Click here to add your own comments

Feb 04, 2014
fire system
by: Doug in s.d.ca

You don't say what your normal cutout should be, but sounds like it is 20PSI, or a bit more than atmospheric x 2.

If that's the case, then your system has a leak.

Consider:
Motor cuts off at 20, while compressor is pumping air like crazy...
Leak drops pressure below cut-in almost as soon as it stops.
Motor starts again - ad infinitum, until the motor overloads.


Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Speedaire.

Speedaire got tipped over and now piston is locked

by Wes
(Midland tx)

Got tipped over on carborator flooded, now piston locked. Won't pull start, or key start

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Speedaire.