I turn it on and the motor wont run and it vibrates

by John

I turn it on, and it just vibrates. No motor running oil level is fine

Comments for I turn it on and the motor wont run and it vibrates

Click here to add your own comments

Oct 05, 2015
No motor and vibrating compressor
by: Bill

Well John, if the compressor motor isn't running, and it's the motor that runs the compressor pump, I'm puzzled as to how the compressor could vibrate without the motor running?

Please provide more details, and at the same time, what is the model number of your Kobalt please?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Kobalt Air Compressor Issues.

Kobalt shakes so much it walks

by Bill
(Cleveland)

Shakes so much it walks and pulls the plug. Looking for manual for disassembly.

Comments for Kobalt shakes so much it walks

Click here to add your own comments

Oct 02, 2015
Shaking
by: Bill

Also, get the cover off and check the drive train including the connection between the motor and pump.

Also, if the motor has a fan, make sure it's secured and not missing a blade.

The motor mounts could be an issue. Make sure that the pump and motor are secure.

Oct 01, 2015
My bad.
by: Bill

It is a 17 gal. horizontal tank,1.5 hp. Blue tank and Grey plastic cover on the compressor. I will post the model # tomorrow as soon as I find my glasses. and there is enough light to read.

Oct 01, 2015
Shaking air compressor
by: Bill

It's always good to know the model number so that folks with a similar model can offer advice.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Kobalt Air Compressor Issues.