jobsmart will not build any pressure at all

by Dean
(columbia sc.)

10 gal. Horizontal runs great will not build any pressure at all I've checked lines fittings pop off valve and cannot find any leaks

__________________
Dean, start by pulling the intake filter, and then feeling if the intake port is actually pulling in air when the compressor motor is running. If not, your first problem is the intake valve may have failed.

Then, see the troubleshooting section on the site map page, and follow the links to the pages about why air compressors run (even if they run great) but will not build pressure.

B.

Comments for jobsmart will not build any pressure at all

Click here to add your own comments

Jul 25, 2013
my rigid compreser wont pumo over 50 psi
by: adams const.

My electric rigid compressor will only pump up to 50 psi and just keep running and will not shut off it is the 5 n 1 rigid that u can split apart and use as a pump only r a tank only it is less than a year old it was running fine one day and then all of a sudden only pump up to 50 psi please help
_________________
Take a look at the sitemap page, under troubleshooting, and follow the link to the page that explains why an air compressor will run and not build pressure. Do the checks referred to.

All things being equal, it's likely a valve or gasket problem, which means a valve and gasket repair it and a tear down.

B.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Jobsmart - Tractor Supply Forum.