Husky motor slows down during pump up

by Elvis Morris
(Olive Branch, MS.)

Additional info. Have changed out the electric motor, Valve plate, In tank pressure switch and Condor pressure switch.


Motor still slows down after pumping up to 25 to 30 PSI.

Could it be a broken piston ring causing the problem. Can't be much more left to be bad.

Comments for Husky motor slows down during pump up

Click here to add your own comments

Mar 22, 2016
Motor
by: Doug in s.d.ca

Would be nice to know the model.

Anyway, this sounds like a power supply problem. Do you know the voltage is OK at the motor? Does the voltage hold up as the motor slows?

Mar 22, 2016
Husky Compressor motor slows down.
by: Anonymous

Original post was that motor would slow down and shaft would get hot after pumping up to 25 to 35 PSI. Changed out run and start caps. No change. Changed out motor, no change. Replaced Condor pressure switch, no change. After that, replaced valve plate and in tank pressure switch, still no change. What is left to look for. Could it be a broken piston ring allowing pressure to build on the piston before getting to the tank valve. About to lose my religion. Thanks in advance for any advise or help.



Mar 21, 2016
Elvis
by: Doug in s.d.ca

I guess Bill couldn't find your other post either.

Please resubmit your info as a comment to the original post.

But I don't recall whether you've checked the check valve, so do that if you didn't.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Husky Air Compressor Issues.