Husky 20 gallon air compressor not working properly

Husky 20 gallon air compressor

Husky 20 gallon air compressor

compressor is 3 years old.


when you plug it in (directly to wall) it starts and makes it to about 70psi (it is rated for 150psi) then just stops.

i listen for air leaking and there is none.

i have taken the plastic shroud of the unit to get to the motor and wires. when it stops, i put a volt meter on the pressure check valve (located directly after the on/off switch), on the out going side it reads 115v. after that the wire dissappers in the motor and i can't find it.

if you unplug the compressor and wait, sometimes it will come on again and continue to climb in pressure. (yesterday i got it up to 125 before it shut down)

i bled some pressure off to see if it would start back up and it didn't. I'm pretty sure i heard the unloader valve release a little pressure when the motor shuts off.

not sure what to do next......i could find a 'button' to push for a thermal overload.

the only else i can see on the unit is 2 capacitors and what ever the bronze colored thing is in the picture i attached


thanks for the help!!!!!!

Comments for Husky 20 gallon air compressor not working properly

Click here to add your own comments

Aug 20, 2015
stops
by: Doug in s.d.ca

OK, so it's one of those integrated motor/pump types.

It's sounding like one of two things - either the new run cap is bad, or there is a bad winding in the motor, or it may be there is a bad connection from the run cap to the motor.

So, with the unit unplugged and cooled off, put your meter across the run cap and if no voltage, check ohms. It should be close to zero, as in an ohm or two, perhaps. You're looking at the cap with the motor winding in parallel.

Disconnect the meter (you can leave one lead connected, if that's easier) and turn plug in and turn on the compressor. Wait for it to stop.

Unplug the compressor and recheck for volts, and if no volts, check ohms again. Does it read the same as the first time? I suspect you'll see the same as when you check the capacitor by itself - if so, then the motor winding is opening under heat stress.

Let us know what you find.

And to be clear, in your photo, the motor is running, yes?

Aug 19, 2015
model number
by: Anonymous

written on the side of the tank
husky model # 947265
f/n 2003669
made 06-2012

hope that helps
i didnt see anything written on the motor itself

Aug 17, 2015
Crud.
by: Doug in s.d.ca

Well, like Bill said, it's likely the motor.

Is there a motor shop near you? You could take it there to have it checked. But before you do that, have you got a model number for this machine and/or the motor itself?

There's something about this that doesn't seem quite right to me but I'm not pinning it down, and having models may help me figure it out.

Aug 17, 2015
checked on your ?s
by: Anonymous

from a cold start i reached 100psi, (the new pressure valve says 150)

the centrifugal switch comes on simultaniously with the motor starting. the motor sounds normal and up to speed.

i kept my hand on the motor the whole time. it got really warm but not hot enough that i had to take my hand off. i didn't notice any smells (like something burning or melting)

thanks again for the help.....what else should i do?


Aug 17, 2015
re: take two!
by: Doug in s.d.ca

I feel ya.

So, from a cold start, it goes for some time less than enough to fill to cutoff (or even to cut-off)? and won't restart for a while.

How's the motor temp right after it stops? Any odor?

Can you watch the centrifugal switch while it's running? Does it operate shortly after the motor starts?

Aug 16, 2015
Compressor motor won't come back on
by: Bill

If power is passing the switch to the motor circuit even with the compressor off, it points to a motor failure.

If power is not passing the switch to the motor circuit when the compressor stops, and if the tank pressure is below the normal cut out pressure setting, then it's likely the switch that's failed.

That you have replaced the start caps, the pressure switch, the run cap, and assuming that all were installed correctly and are the correct replacements, and your compressor shuts off before the tank pressure reaches cut out, and the pressure switch is still passing power to the motor circuit, then it's electrical, and all else being new, the problem must lie in the compressor motor.

Centrifugal switch perhaps or the motor itself opening a short when the windings warm up.

Aug 16, 2015
take 2!
by: Anonymous

so, since i wasn't good at checking ohms, i bought a new pressure switch, start capacitor and run capacitor. put all the in, and it still does the same thing......runs for a bit then shuts off with out reaching 150psi and won't come back on even if i pull the bleed-off valve.......

what else is there to replace?!?!?!!

thanks for the help....this is super frustrating


Jul 26, 2015
testing capacitors
by: Doug in s.d.ca

....

Does that mean you got to where you switch to ohms?

And watch the ohms go up, and reverse, and see the ohms go negative and then back up?

Jul 25, 2015
checked capacitors
by: Anonymous

i checked both the capacitors like it said to... i used a digital multimeter, set it to DC........

the volts would go up to 3v, then i switched which tabs the leads were on and it would to -2.8v. i switched back and forth multiple times on each of the 2 capacitors....both seemed fine


any other thoughts out there?

Jul 20, 2015
capacitors
by: Doug in s.d.ca

See the section on checking capacitors.

The bronze thing is the centrifugal switch the cuts the start cap out as the motor gets to speed.

Please let us know what you find in a comment.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Husky Air Compressor Issues.