HF 61454 Won't Go above 30 PSI

by T
(Oregon)

I've done extensive digging through this site and feel like I'm on the right track, except for one detail. . .


The "Start Valve" (according to the manual, which I'm assuming is the same I've seen referenced as a "Cold Start Valve") on the top of the unit (Central Pneumatic 61454 2.5HP / 21 Gallon from Harbor Freight) constantly let's air out when the compressor is running. I seem to remember having this issue in the past, but pressing the valve stem in quickly remedied the issue. I've tried dismantling it and stretching the spring, and compressing the spring, and manually pulling the valve closed with pliars, with no success in getting over 40PSI so far.

I also removed and cleaned the Check / One-Way valve which looked brand new inside still. I've only the had compressor less than a year with low to moderate use maybe a few times a week.

No air leaks from anything when the compressor is turned OFF, but I did notice air coming from what i believe the unloaded tube behind the "Lefoo" pressure valve, but only when the compressor is running. Is this normal behavior?

Could it be I just need a new cold start valve, or does this sound like something more serious?

Comments for HF 61454 Won't Go above 30 PSI

Click here to add your own comments

Jul 30, 2017
Won't get over 30 psi
by: Doug in s.d.ca.

Oregon T:

Sounds like you're on the right track - read this:

http://www.about-air-compressors.com/pressureswitch.html

That should take you to the solution. If not, come back and let us know what else you found.

Good luck.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Compressor Will Not Build Pressure.