GA 22 Atlas Copco comes up for a few seconds then shuts back down

by Christopher
(Conroe, Txeas, U.S.)

The company I work for acquired a AtlasCopco GA 22 screw compressor.


After installing when we try to start it if comes up for a few seconds then shuts back down. If we go into the history on start up it tells us Motor/ fan motor overload.

Now we've checked all wiring and everything is good but we never get long enough to check the motor rotation to see if its turning the correct direction.

Could it be the motor in spinning in the wrong direction and giving us the fault or protection shut down?

Comments for GA 22 Atlas Copco comes up for a few seconds then shuts back down

Click here to add your own comments

Nov 19, 2016
GA22FF
by: Anonymous

Yes I used the rebuild kit to rebuild the inlet valve I also have ordered the kit for the minimum pressure valve didn't know if that would also have anything to do with it when the compressor starts up it does fine for a couple seconds then all of a sudden sounds like it comes to a halt when it goes to kick in the fan would cause this to happen? Also how would I test the fan to see if it is bad?

Thanks for the help

Nov 18, 2016
Fan motor overload
by: Doug in s.d.ca

So have you checked the fans (some have one, others, two)?

There's maintenance on them.

Nov 18, 2016
Fan overload
by: Carl

So, the fan overload first.
You have the main motor and then you have the fan. Both have overload protections. If the bearings are going on either, it will trip. So look if you have bearing problems or even power problems going to the fan, could also be the overload itself has weakened, if you can, turn the setting up then check the amp draw on the fan motor.
Oil going up the air filter.
The inlet valve sounds like it isnt closing quick enough when unloading (lazy inlet valve) you say you have rebuilt it but you may need a service kit to replace the seals and spring, that should sort it out.

Hope that helps

Carl

Nov 17, 2016
GA 22 atlas copco shuts down after few seconds
by: Anonymous

I am having this same problem on my GA22FF it has ran fine for over 3 years now when you cut it on it runs for maybe 3 or 4 seconds then shuts off with fan motor overload. also has oil backing up into filter on inlet valve. have never used the emergency stop button. oil level is good, also rebuilt the inlet valve today but problem is still the same... anyone have any clue what it would be?

Sep 09, 2016
Maybe...
by: Anonymous

Or oil stop valve ?

Apr 23, 2016
Compressor motor direction
by: Carl

Yes it does sound like the motor direction by your description but it is easily resolved.

You need to isolate the power on the wall, then the wires going into the compressor (L1,L2, L3) just swap the L1 and L2 over then switch on and try it again.

Reply to this post to let me know how you get on.

Hope this helps.

Carl

Apr 22, 2016
GA 22
by: Doug in s.d.ca

I presume it's 3 phase.

Go ahead and try reversing. If it then works, great.

If not, then we gotta think harder - like, was it working right before you bought it?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.