Cord sparks when plugging it in

by John Wagoner
(Riddle Oregon, United States )

My 26 gallon craftsman compressor, I had to replace the plug in on the electric cord (stepped on the old one, broke off the ground ) but now when I plug it in it sparks and wants to melt the plug. I have triple checked that I wired it correctly, I am using a extention cord,not sure what could be causing this.

Comments for Cord sparks when plugging it in

Click here to add your own comments

Apr 09, 2017
Cord sparks
by: Doug in s.d.ca.

As Bill said - a short.

Could be in the cord itself, since you stepped on it.

In any case, for this sort of thing, if you don't already have some type of volt-ohm meter, you should spend a few bucks on one and learn how to use it.

Not that you should spend a lot on the V-O-M, but Tripplet has some very good tutorials on how to use them.

Apr 09, 2017
Craftsman cord sparks
by: Bill

Are you saying that power arcs to the plug when you are trying to plug it in to the wall socket?

That suggests that you've got a bare wire in the circuit somewhere that's touching ground.

What plug did you replace, the one on the extension cord (which you shouldn't be using anyway) or the one on the power cord for the Craftsman compressor?

If the extension cord, try plugging the compressor right into the socket and get rid of the cord.

If the issue is with the compressor power cord, and you've done nothing else besides replacing the plug, then I suspect you've got a wire in the plug either connected to the wrong terminal or another wire.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Craftsman Compressor Issues.