Central pneumatic compressor shuts down before reaching pressure

by Michael Brown
(Solvang, Ca.)

I have a Central pneumatic Compressor that will start up fine but will shut off before pressure is reached.


I have checked the Pressure Switch and it is fine . ie if tank is holding 60 psi and I start it with pressure switch set a 70 psi it will run to 70 turn off and if I bleed air off it will restart by itself as expected.

If I start from 0 psi it will shut off before it gets to shut off pressure. If I wait a bit reset button clicks and I can reset it and it starts again. Can It be a running capacitor/ starting capacitor or is it more likely just getting too hot from motor getting to the end of its days. Any easy way to check?? These are cheap compressors so obviously dont want to "waste too much".

_________________
Bill says...

You've checked the pressure switch Michael, and you say it's fine.

When the compressor shuts off prematurely, is it the pressure switch that is shutting it off, or is the motor going off on reset?

If the pressure switch is toggling off power to the motor before its set point, then my money is on a bum switch.

If the motor is going off on thermal overload, then your guess about the run capacitor may be right on the money.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Central Pneumatic Air Compressor Issues.

only makes up to about 50psi and just keeps running

by T. Dexheimer
(San Diego, California)

when you start the compressor it builds pressure to about 50psi, but no higher and the thing never shuts off.

___________________
Bill says...

Drive you nuts, huh?

Have a look at the Troubleshooting page, and click the link to compressor will not build pressure. Have a read, and do some of the checks referred to on those pages.

If you have any more questions, it would be useful if you could give me them as a comment here, so that I can follow our discussion as we try to figure out what is happening (or not happening) with your air compressor.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Central Pneumatic Air Compressor Issues.

central pneumatic fills up, shuts off, then trips GFI

by chris
(las vegas, nv, usa)

I have a small central pneumatic 8 gallon compressor model number 94355. It has worked fine for years and now occasionally (not all the time) fills up, shuts off, and then trips the GFI. Thanks in advance for any help you can provide.

Chris

___________________________
Bill says...

Chris... turn off the compressor. Drain the tank completely. Turn it on. Does it start?

Let it run for fifteen seconds. Shut it off.

Drain the tank.

Turn it on. Does it start OK again?

If so, I suspect your unloader valve isn't dumping air over the piston.

Let the compressor run to full cut out, and check to make sure the unloader valve works (page on this site with details about the unloader valve).

If the unloader works every time, post this info as a comment here.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Central Pneumatic Air Compressor Issues.

Only builds to 50 psi?


(Steve)

3hp 21 gallon central pneumatic compressor only builds to 50 psi

i have a 3hp 21gallon central pneumatic compressor. i bought it at an auction and noticed that half of the air filter assembly was missing. i plugged it in to try and it pumps up to 50 psi good but no further.

i have took the head off and reed valve looked good piston looked good as well.

i did notice when its running it vents a lot of air out oil filler cap. i have not disassembled flap inside of head. what do you think is wrong?

p.s. i have also messed with pressure switch thats not it either

thanx
steve
__________________
Steve, good that you checked the valves.

A key clue for me though is the air bleeding out the oil fill cap. Where do you think that air is coming from?

Typically, that is a sign of worn compressor cylinder seals. The more wear, the more air that bypasses them into the sump instead of going into the compressor tank, and the more air that bleeds out the oil fill cap.

The seals in your compressor may hold until the tank pressure gets near the 50 PSI level, and then, the increasing back pressure forces the piston seal(s) to leak. Air will always follow the path of least resistance, so, it seems that it is easier to blow the cylinder seals open than it is to exit through the pressure valve and into the tank past the tank check valve.

A pressure at 50 PSI (or any pressure level) with the compressor running is also an indication of a gasket leak inside the pump. My rule of thumb is if you are going to tear down the pump to check things out, have a gasket kit on hand to replace them, and ensure that they are not the problem.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Central Pneumatic Air Compressor Issues.