Campbell Hausfeld Will
       Not Build Pressure

A number of folks have problems when their Campbell Hausfeld will not build pressure. Here are a few of their questions and responses.

Question:I have a cambell hausfeld wl6701 that will not build air pressure although every thing seems to be operating normally can you help?

Response: Your compressor cannot be operating normally if it isn't building pressure now, can it?

Please shut of the compressor, drain the tank from the tank drain, shut tank drain, and restart.

Does it start properly now?

Let it run for a couple of minutes and monitor the tank gauge. Any change whatsoever from the zero reading it should have when you drained the tank?

If no pressure is built, shut the compressor off, and find the intake port. Start the compressor. Is air being pulled into this port as the compressor runs? You might have to remove the intake filter to check this.

Comment: about Harold's WL661100AJ.

Yes, air is being sucked into the air intake.

Response to comment: Harold, as long as air is only being pulled in, and not huffing back out, then that suggests that your intake valve is good.

That leaves a pressure related gasket leak, or a high pressure valve to be checked. Those will required a tear down, I'm afraid.

A new Question: Just bought a used 5hp 20 gallon compressor (VS500602AJ) and it seems slow to fill. It takes about 4 minutes to go from empty to the cutoff at 125lbs.

I do get a little puffing at the intake which leads me to think that I'm losing some of the charge back out the intake.

The rear bearing on the motor is a little noisy also. What do you think?

Question: Ian, yup, that sounds a bit slow, but not too bad, considering the great deal you got... did you?

You will have to do some re & re on the intake valve, and I suspect the high pressure valve too. They may be part of the same plate.

If you can't lube the bearing, then I suspect its not long for the world either. Yet, you can still use the compressor, and weigh what you would spend in time and money against the cost of rebuilding, and maybe just use it up?

Comment: by: Ian. Changed the oil in the pump a few minutes ago and it looked like creamy white gravy. Looks like this compressor might not have been such a good deal after all. Thanks Bill.

Response to comment: That might be the presence of water, a by product of compressing air, and indicative of piston seal leaking. Might be that's all it needs.

But, are you getting air out? Is it doing work for you? Might have been a good deal after all, like my $10 air compressor I talk about on my videos page.

Comment: by: Ian. Yes, I get air out of it and it does ok, just slow to reach cutoff and slow to recover. I bought it primarily to provide air for a plasma cutter. I'm hesitant to put much money into it. A set of valves costs $41 and if the motor goes, that's $130 at Harbor Fright. It's also missing the intake filter that runs $9 plus shipping. That would put me at about $185 and I would still have a compressor with a 9 year old tank that I got about 2 cups of rusty water out of. I think I'll just "use it up" as you put it and buy new next time. Hopefully the motor or pump will fail and not the tank. OUCH! Tanks for the help Bill. :)

Response to comment: Most welcome. Delighted to provide any help. Tell me Ian, is the spelling of HF's name a Freudian slip?? :-)

Comment: by: Ian. Purely intentional Bill, purely intentional... LOL