Cambell Hausfeld compressor just hums and does not start

by Robert Jones
(Prescott WI)

Oil is not the problem, it is fairly clean - less than 50 hours on it. Electricity is good at 30 amps and good contact. I may be wrong on the unloader valve issue...

______________________

Robert, you've made it to the TROUBLESHOOTING page, and you've picked up on the fact that it might be the unloader valve.

But, is the unloader valve working on your air compressor?

Turn off the compressor, drain the tank to zero PSI, and then try to start it. If it starts at zero PSI, but won't start at normal cut in pressure levels, then check the unloader valve first.

Cheers,

Bill

Comments for Cambell Hausfeld compressor just hums and does not start

Click here to add your own comments

Oct 20, 2011
found problem
by: Anonymous

The problem was actually the piston froze in place. tore the motor apart and released the piston. will hone out the cylinder and rebuild with new gaskets and new oil and compression rings, should be good to go, cross your fingers...

________________

They are crossed. Good luck. Piston froze? Been that way myself a couple of times. :-)

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

Oil dipstick won't stay in place

by dave
(carbondale, ks)

the oil dipstick won't stay in place, shoots or pops out when I start the compressor
_________________
Dave, the dipstick cap should be vented. If that is plugged that might account for this happening on your air compressor.

However, if there is lots of air coming out the oil fill tube after you remove the cap, that suggests to me that you have some issues with piston seal wear on your pump. You need to check that out.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

VT558705AJ WILL NOT PRODUCE AIR

by ALAN ZEIGLER
(ROCKFORD MI)

TUNED IT UP THE OLD GIRL RUNS BUT WONT PRODUCE AIR (IM THINKING A COMPRESSOR REBUIlD)
________________
Not a lot to go on here, Alan.

The first thing to check is whether or not the pump is pulling air into the intake port. Remove the intake filter and check. Strong suction, no blow out... what do you find?

Post a comment here with your findings please and, I suggest too that you visit the troubleshooting section on the sitemap page and read the pages to do with why air compressors run but don't build pressure.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

Cambell Hausfeld MC015502SJ motor RPM?

by Gabe Clark
(Decatur, AL)

I know this motor is used on a lot of different compressors (mine is a Husky), but I am in the market for a new motor and cannot find anywhere (Included CH's website) of what RPMs this motor turns. Can you help so I can get a comparable motor?

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.