Campbell hausfeld 64ooooaj 13 gallon Plug in compressor - nothing happens

by John
(Sunnybrook ca 95640)

Campbell Hausfeld 64ooooaj 13 gallon Plug in compressor - nothing happens


I just got this used compressor but motor seems to not be running. I by passed the hot and neutral on the air switch and checked the pull out fuse near the motor but still nothing. Are there other fuses on the motor. There is a bundle of wire before each brush on the motor Not sure if there is a switch or fuse in there

Comments for Campbell hausfeld 64ooooaj 13 gallon Plug in compressor - nothing happens

Click here to add your own comments

Jun 04, 2015
Correct model number is
by: John

WL640000AJ

Jun 03, 2015
Compressor image upload
by: Bill

Hi John... start a new thread here in the Campbell Hausfeld compressor section, and in it, refer to this post:

Campbell hausfeld 64ooooaj 13 gallon Plug in compressor - nothing happens

Then you can upload up to four photos, and I can move them so that they are all together.

But, you still need to determine if power is getting to the motor circuit, with the tank empty.

B.

Jun 03, 2015
Pictures of compressor model info and machine
by: John

Would like to post pic of model info but not sure I can here

Jun 01, 2015
Oh - I'll check model number again
by: Anonymous

Need a new multi meter - mine is dead

Jun 01, 2015
Campbell Hausfeld 64ooooaj
by: Bill

No such compressor as a Campbell Hausfeld 64ooooaj according to Google, John.

When you use your multi-meter to track how far the power is getting, where does it stop?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.