c2005 type 3 compressor not building pressure!

by Zach
(Maryland)

I have a c2005 type 3, air compressor.. I have replaced all gaskets, pressure switch, and regulator.


My compressor will build to 50 psi, and shut off.

It will then turn on for a few seconds and shut off. This will repeat on and on building no additional pressure. I have not tested the amps yet, but am at a loss as to why the compressor does this. Any ideas?

Comments for c2005 type 3 compressor not building pressure!

Click here to add your own comments

Jul 30, 2016
Video Reference
by: Anonymous

I am going to check the amps this afternoon. In the meantime I have posted a video on you tube of my compressor. It will give a good idea of what I'm talking about. You can search under porter cable c2005 type problem. I'll check in again. If anyone watches this let me know what you think! Thanks!

(Add a comment here with the actual link to the video if you wish. - Moderator)

Jul 29, 2016
c2005 type 3 shutting down
by: Bill

First thing I would check is whether, when the compressor shuts off, power is still flowing across the pressure switch.

If power is flowing and the compressor is not running, that points to the motor as being the likely cause.

If power is not flowing, and the tank pressure is below the normal cut out pressure, then it is likely the pressure switch itself has failed, or is set wrong.

Please advise which scenario is correct.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Porter Cable Compressor Issues.