Campbell Hausfeld brand new regulator leaks?

by Ralph

Hi Bill,


I have a 25 Gal. Campbell Hausfeld air compressor.

My problem is when i put oil and water filter regulator in the output line via rubber hose connection after the compressor reaches the set line pressure of will say 40# the regulator starts to leak air causing the compressor to run for long periods of time.

I cant seem to resolve this problem with new regulators. What would cause a brand new regulator to leak like that. Have checked gaskets and tightness of bowls.

I run a lot of air body tools that i need oil addition too and don't want water in the system either. They seem to leak at the air pressure adjuster on the regulator.

__________________
Ralph, did this start to happen with an older regulator, or did it start after you replaced the regulator?

Comments for Campbell Hausfeld brand new regulator leaks?

Click here to add your own comments

Feb 20, 2015
Regulator
by: Bill

Is the regulator installed in the correct orientation?

Bill

Feb 20, 2015
questions about new regulator
by: Dennis

im having this same issue with my regulator just got a brand new Campbell hausfeld 80 gallon 5 hp compressor works great but the regulator leaks when I set the air output on it. just out of the adjuster bought everything brand new??

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

DP4615 won't run

by Paul
(Washington State)

I have a dp4615 air compressor that won't run.

I tested for 240 volts at switch (120 each line) at 240 at motor.

Voltage was good with switch on and verified no power to motor with switch off.

Thought this was a cut and dry motor so I bought one from Century, identical motor and identical part number.

I still have the same problem. Could there be something else or did I get a bad motor?

Can the pressure cause this even though it tests good for power?

Thanks
_____________________
Hey Paul.

You indicate that you are getting power to the motor itself, so that suggests to me that the pressure switch is working fine.

When you replaced the motor, did it come with new capacitors, or did you reuse the old?

If power is getting to the motor circuit, and there is absolutely no response from the motor at all, that suggests to me that the start cap is pooched.

If you have new caps and a new motor, and you have sufficient power to the motor, then all I can guess is the motor is still not right.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

Will not put out enough air to run air impact

by jesse freelen
(paris,texas)

tank runs up to 120 psi but the air impact seems like it does not have enough pressure to operate the air gun. It has worked for the last few years fine.
________________________
OK Jesse, if the impact wrench worked fine being powered by this air compressor before, and it isn't now, clearly something has changed.

When you say that the wrench isn't working properly, that the compressor isn't sending enough pressure, are you certain that the impact wrench is OK? If it's slowing down, then maybe it's worn out, or needs lubrication. After all, an impact wrench has vanes and seals that wear out, and when they do, though the air supply and pressure going to it don't change, the tool will appear to be running out of power.

Having said that, the air flows from the tank to the regulator to your air tool, right?

If nothing else has changed, then it is possible that the air regulator is reducing the flow, and that may be the problem.

One way to check is to empty the tank of air, remove the regulator, put the discharge coupler where the regulator was, and run your air tool - briefly - at the full tank pressure. If the tool runs OK, that pretty much says that it's your regulator that has failed or is in the process of doing so.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.

Cambel hausfeld 6 hp compressor

My CH compressor 6.25 peak HP 1.8 HP 28 gallon 150 psi will only go to 60 lbs and wont cut off.
________________
A not unusual complaint.

Could be a number of things... intake filter plugged, intake valve failing, pressure valve failing, piston seals failing, even possible the tank check valve creating the problem.

See the troubleshooting section on the sitemap page and follow the links to the pages that address this compressor problem.

B.

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Campbell Hausfeld Compressor Issues.