Atlas copco xrhs 366 "engine not responding " fault code

by mandlenkosi dube
(zimbabwe)

my xrhs 366 shuts down after running for a few minutes and displays error code " engine not responding" please help am stuck

Comments for Atlas copco xrhs 366 "engine not responding " fault code

Click here to add your own comments

Apr 13, 2016
not responding
by: Doug in s.d.ca

Hmmm.

Is the throttle control visible? Can you check if it's maybe sticking when the temp inside the enclosure gets too high?

When you changed filters, did you check for one inside the fuel tank?

How many hours on this thing?

Apr 13, 2016
engine not responding
by: Anonymous

i also was suspecting filters so i changed them but still it did the same thing

i fear for the worst if its the pump cause its very expensive to service or buy one

Apr 11, 2016
366
by: Doug in s.d.ca

Have you checked the fuel filter? Sounds like it may be starving for fuel due to partly clogged filter. Hope it's not the pump.

Apr 11, 2016
engine not responding
by: Anonymous

it starts well and loads very well .if you open the air outlet it runs for a few minutes drops rpms from 1800 to 1200 and drastically cuts and displays engine not responding

Apr 10, 2016
366 compressor not responding
by: Doug in s.d.ca

Is the engine responding? Does it run? die when you open the output valve?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.