Can't get XAS 185 to load

by Andrew
(San Francisco Bay Area)

I have an XAS 185 375 CFM that I use for sandblasting. I am unable to get the compressor to load properly when attempting to pressurize my sand pot.


I usually run between 90 - 110 lbs of pressure at the valve. In the past when it was working properly I would engage the remote and the pop-up valve in my sand pot would pressurize the system.

During this process you could hear the compressor gearing up when the load was put on it.

Now I am having problems getting the pop-up valve to seat itself on the first attempt. You can hear the piston in the pot trying to pressurize as if it wasn't getting enough pressure. Sometimes it takes several attempts to pressurize the system and when it does, it does not gear up.

I have rebuilt the pistons and other hardware on the pot, replaced air lines and the remote to no avail. I think it might have something to do with the linkage on the compressor. Any suggestions would be great as this has become very frustrating. Thanks

Comments for Can't get XAS 185 to load

Click here to add your own comments

Dec 19, 2015
Low pressure??
by: Doug in s.d.ca

So, are you getting/maintaining the 90-110 psi you normally did, or not?

If not, then yes, that sounds like it would be either a linkage or maybe sensor problem.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

On a Atlas Copco XAS 185 what type of oil it takes at the Compressor Pump

by Cesar
(Paterson N.J, U.S,A.)

On a Atlas Copco XAS 185 what type of oil it takes at the Compressor Pump

Comments for On a Atlas Copco XAS 185 what type of oil it takes at the Compressor Pump

Click here to add your own comments

Jun 24, 2015
oil
by: Doug in s.d.ca

Copco oil.

No, not kidding.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

Atlas 185 won't start and was blowing oil out the main air line

by Walt
(mobile al)

im working on an atlas 185 tow behind its an oil injecters first it was blowing oil out the main air line so I took the air filter off and filled it up with the right amount of oil crunk it up it ran for about 10 min and cut off and now it won't start back up what can be the problem

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.