Oil separator element busts - compressor builds smoke

by Ashish Dass
(Fiji)

Atlas Copco GA608 oil separator flange

Atlas Copco GA608 oil separator flange

Atlas Copco GA608 oil separator flange
Atlas Copco GA608 oil separator element from top
Atlas Copco GA608 oil separator element
Atlas Copco GA608 oil separator element flange closeup

Atlas copco GA608 oil separator element busts and becomes out of shape. Oil comes in the air line, and the compressor builds up smoke.

Comments for Oil separator element busts - compressor builds smoke

Click here to add your own comments

Sep 04, 2015
When?
by: Carl

Is this how you found your sep element just once? Or does it keep happening? I cant quite see in your photos but has the element imploded? When was the last time it was replaced? It is supposed to be replaced every 4000 running hours or annually (whichever comes first). Are you using the correct oil?
Please reply to this message with your answers
Kind Regards

Carl

Sep 03, 2015
separator
by: Doug in s.d.ca

Sounds like the scavenger tube is plugged or not positioned correctly.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

Air Compressor tripping on low pressure

by Shadab
(Dubai)

Air Compressor tripping on inter-cooler low pressure

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

atlas copco compresser kicks the breaker

by Dan
(michigan)

it is an atlas copco compresser with a 5hp baldor motor it says its a36e937w500 with a 184t frame

starts and runs for a half hour then kicks the breaker

Comments for atlas copco compresser kicks the breaker

Click here to add your own comments

Aug 04, 2015
Kicks the Breaker
by: Marty

Put an amp probe on the power supply line and check the amperage draw at full load when the air compressor gets near its set cut out pressure. Then check the breaker rating. the panel should be a little higher rated than the measured amperage. if not then replace the breaker with the next size larger.

If the breaker is large enough then it could be worn and not tripping at its rated value.

Jul 20, 2015
Which atlas copco?
by: Doug in s.d.ca

Have you checked the capacitor(s)?

Which breaker? At the supply or the motor?

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

Compressor shuts down

by Ricardo

Hey. I have an atlas copco with cat c6.6 Acert engine.

Lately, when i load the compressor it shuts down, giving injector 4 fault.

The issue is that I already replaced that injector and keeps giving me the same fault.

I checked the wiring and everything is as it should be.

When not on load, the engine runs great but as soon I press the load button it shuts down giving the injector fault.

May the whole injection system be compromised? Then why is it giving a fault on injector #4?

Best regards and thank you in advance mate.

Comments for Compressor shuts down

Click here to add your own comments

Jul 14, 2015
fuel rail
by: Doug in s.d.ca

You could also perhaps just transpose the new injector with one of the others to verify the problem stays with #4, if that's easier for you.

Then,

Check the pump - could be sick.

Might just be a gummed up filter or intake at the fuel tank.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.