Atlas Copco LT5. Stopped ???

by Al
(Vancouver BC)

Our LT 5 just stopped pumping ???


I think the motor over heated.

Is there no reset on the motor ???

Do I have to let it cool down to room temp before it re starts ???? & do I need to put a fan on it to keep it cool now ???

Always fails when you need it most

Comments for Atlas Copco LT5. Stopped ???

Click here to add your own comments

Jun 16, 2015
Atlas Copco LT5
by: Doug in s.d.ca

Well, if you think the motor overheated, that begs the question "Why?"

But, have a look at the troubleshooting section for why compressors won't start.

I don't see anything specific about the motor, but they often have a thermal cutout, so you'd need to let it cool off before it restarted. Sometimes there is a thermal fuse inside the motor - but if that lets go, the bearings are likely shot.

After doing the basics, if you need to come back, then please tell us which motor you have (voltage, mainly).

Jun 16, 2015
Oil?
by: Carls421

I suppose the first questions would have to be Is the oil level correct? Do you have the correct oil in the sump? And when was the last time you had a complete oil change? You shouldnt have to have a fan pointing onto the compressor as it is already air cooled via the fins on the head, they should be sufficient. The oil level should be around 3/4 of the way up the sight glass

Hope this helps

Carl

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.