62299 will not re-pressurize

Hello--I have a Central Pneumatic 60 gal upright compressor Model#62299. It was working fine, turning back on when the pressure dropped to the correct level.


Then, for some reason it just quit and did not re-pressurize.

I checked the breaker, no problem there. With a volt meter I also checked the socket and got power, removed the plate on the back of the motor and checked for power on the terminals there (also good--pressed the reset button as well with no response), pulled the cover off the pressure regulator and got power to the terminals there.

Does this mean that the pressure regulator is bad and needs to be replaced?

The motor will not turn on no matter what I do, including draining the tank down to zero. Any ideas?

It's an almost new machine but out of warranty as I have owned it for more than 90 days. I'm in the middle of an important project and really need the unit to function. Thanks very much for your advice!

Comments for 62299 will not re-pressurize

Click here to add your own comments

Jun 12, 2017
62299 will not run
by: Doug in s.d.ca.

So, you're running it on a 220V outlet, rather than hard wired?

(220 is anywhere from 208 to 240V, depending on the source)

And when you saw voltage at the motor, you measured 230-240V across the terminals?

If so, then the motor would seem to be bad. If not, then you need to find out why you have what - 120v, maybe? Ya gotta have 220V to 240V.

BTW, do not measure to ground - you need to measure across the terminals for 230V circuits.

Good luck.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Central Pneumatic Air Compressor Issues.