3hp sanborn magna force slows way down

by Tom Connell
(United States)

sanborn 3 HP magna force air compressor

sanborn 3 HP magna force air compressor

I just bought a sanborn 3 hp magna force compressor. It looks to be rather new.


When I turn it on it starts pumping but quickly slows way down and quits running before it gets to 30 lbs of pressure.

I took the belt off the motor and turned it on and the motor runs fine. When I put the belt back on the same thing happens again.

Any ideas on what's going on with this compressor?
Tom

Comments for 3hp sanborn magna force slows way down

Click here to add your own comments

Dec 07, 2015
Check The Voltage Wireing inside the J box on the motor
by: Anonymous

Sounds like the motor could be wired to run on 220V but the has a 120V plug. that would make the motor run as you describe.

check the schematic inside the cover of the Junction box on the motor to make sure it is wired correctly for your electric supply.

Feb 23, 2015
Not pressure switch
by: Bill

I doubt if it is the pressure switch.

Typically this issue is created by a couple of things. Either the motor cannot overcome the increasing load of a mechanical issue in the pump, or, the motor isn't getting enough power from the source or through the run capacitor.

B.

Feb 23, 2015
mine does same thing
by: Gary

My model #112A300-30N. does same thing. You first tun it on it runs fine but after a few seconds it pulls down and then shuts off (before tank is anywhere close to full) I think it may be pressure switch, but I'm no expert

Aug 23, 2014
3hp sanborn magna force slows way down
by: Bill

Tom, what is the voltage of the motor, and please describe how you are getting power to it.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Sanborn Compressor Issues.