1500e screw doesn't compress any air?

I have a Sullair 1500e screw compressor that starts up but doesn't compress any air. What should I check first?


Thanks!

Comments for 1500e screw doesn't compress any air?

Click here to add your own comments

Aug 22, 2017
coupler
by: jim

my sullair 185 ( Thanks for your comment, though it seems to be about a different compressor or problem than the original post. Please start a new post in this forum and we will try to get you some answers about fixing your specific compressor problem. Thanks. - Moderator )

Aug 21, 2017
Coupler damage
by: Mike 5

Most every one of the units I have repaired that ran fine but produced no air was caused by a coupler that has been destroyed. The cause of these failures is usually related to engine performance issues (poor running conditions).

Jul 29, 2017
Not compressing?
by: Carl

Is it going from star to delta after you press start?
If so then check the intake solenoid, make sure it's getting power, if it is then change the solenoid

Let us know how you got on

Jun 10, 2017
1500e no air
by: Doug in s.d.ca.

Is the control panel not telling you anything?

I can't find much specific to these machines, but *some* have a coupler between the motor and airend which can break...

If you have the manual, start there.

Sorry can't be more help - good luck.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Sullair Air Compressor Issues.