Air compressor suddenly got alot louder

by adam
(26261)

after rebuilding my ch 28 gal compressor it cycled 3 times normaly and on the 4th time it pumped up to 50 pound and suddenly got extremly loud.it now takes nearly an hour to load the talk.iv removed the head and nothing appears broken.although the new valve plate looks like it may have been hot{temper colors on valve}.did the head gasket blow or what/let me know ,thanks.hammernhand@verizon.net

________________
Hi Adam. I think I've seen this post before, but I get so many, I can't be sure.

First guess from me is that you've blown a gasket somewhere in the head that's separating the intake from the compression.

Are you getting any "huffing" out the intake valve too? That's a valve problem, if you are.

Good luck.

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Troubleshooting.

air compressor won't pump air

by larry richison
(rising sun in.)

my air compressor motor runs but will not pump air.

mod # 919.165200

____________________________
Bill says...

Won't pump it out the hose, or won't fill the tank?

Check out these pages on why a compressor won't build pressure.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Troubleshooting.

Alltrade Powerbuilt compressor runs loud and builds pressure slowly

by paul bentham
(Toronto, Canada)

Hi Bill,
My friend's Alltrade Powerbuilt 5 gallon 3 hp compressor runs loud and takes a long time to build pressure to the shut off point. To be honest, I shut it off at 90 psi when I got tired of listening to it and also because it was starting to get pretty hot. I ran air into it from a good compressor and the pressure switch cut out ok at 120. It also runs pretty loud. It did not have an air filter on the intake and the oil is dirty, so I'm thinking the piston rings are worn. Assuming that makes sense, Alltrade will send me rings, gaskets and reed valves for $30. If I replace these parts in the top end and change the oil, will that solve the loud running or is the lower unit likely making the racket?
Thanks, Paul
__________________
Paul, the symptoms suggest to me that the valves are failing.

Since you get them and other items for your $30, it seems to me that by re & re all the old parts for new, you should solve your compressor problem.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Troubleshooting.

a Hitachi Koki ec12 - The preasure will not go above 75 psi.

by keith2337@yahoo.com
(austin texas)

I have a Hitachi Koki ec12, the psi will not exceed 75 psi. I replaced the gauges and the pressure valve that regulates psi to the house, the psi issue is the same. Any suggestions?

____________________
Bill says...

Hi Keith.

Why not have a look at the page linked from under the Troubleshooting section on the site map, "why compressor will not build pressure" for some things you can check.

Then, when you've done the checks, if you still cannot get a resolution, post a comment here telling me you found.

Thanks,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Troubleshooting.