IR5E6VA Ingersol Rand - is it worth buying?

by Larry Miller
(Hutchinson Kansas)

I am looking for info on a INgersol rand IR5E6VA compressor serail number DC91069_16604-0129,


I have a chance to buy it for 125 bucks..... it has new motor on it but they ran it backwards and I think it has valve damage. I need to know what it will cost to fix it and if its worth the trouble( I wanna a New ONE!!)and if i can get parts or not.\

Im mechanical and build harleys and hotrod chevys, so not afraid to work on it to save a few bucks.....
thanks
Larry Miller

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

P130 Ingersollrand stops after 15 min of use?

by Tim

ingersollrand p130 stops after 15 min of use.
the machine does not appear to be getting hot.
I was thinking it may be a faulty sensor or relay.

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

how do you adjust belt tension on ingersoll Rand 25HP Rotary Compressor

Rotary 25hp how do you adjust belt tension

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

INGERSOLL RAND U30H SP COMPRESSOR screeching sound - how come?

by CHRISTIAN DAGALEA
(LONG BEACH , CA)

REGARDING A INGERSOLL RAND COMPRESSOR......I AM ABOUT TO PURCHASE A 30 HP INGERSOLL RAD U30H SP FROM THIS GUY FOR A SUPER PRICE ...BUT THE THING IS IT MAKES A SCREETCHING/ LOUD SQUEAKING SOUND WHEN IT STARTS TO LOAD ...I WOULD SAY AROUND 45-50 PSI....I DOESNT DO THAT WHEN ITS UNLOADING ....JUST WHEN IT GETS CLOSE TO 50 POUNDS.....THE OWNER SAID ITS BEEN HAPPENING REGULAR THIS PASS WEEK SO HE STOPPED USING IT....THERE ARE NO LEAKS ...BUT HE SAID IT MIGHT BE THE BEARINGDS ON THE PULL BUT HE DOESNT REALL KNOW....OIL HASNT BEEN CHANGED BUT FOR A WHILE .....IF YOU CAN HELP ME FIND A SOLUTION TO THIS PROBLEM I REALLY DO APPRECIATE IT......PLEASE TEXT ME AT 562.810.2078 ANY TIME .....I HOPE YOU STILL HAVE THIS EMAIL AND YOU REGULARLY CHECK IT BECAUSE I REALLY NEED HELP....

-CHRISTIAN DAGALEA

CDAGALEA313@HOTMAIL.COM

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

SSR ML75 pushing oil through the air intake filters - why?

by j.moyo
(bulawayo, zimbabwe)

have an Ingersol rand SSR ML75 screw type air compressor pushing oil through the air intake filters, what are the possible causes ?

jothammoyo@yahoo.co.uk

Comments for SSR ML75 pushing oil through the air intake filters - why?

Click here to add your own comments

Dec 18, 2012
Ml 75 oil blowback
by: Anonymous

You have a problem with your oil stop valve not closing or the blowdown valve not working

Sep 03, 2012
Inlet
by: Carls421

Hi, Sounds to me like you have a problem with your Inlet valve, when the compressor goes offload, it should shut immediately, but if it closes slowly, then oil will progress up and out of the air filter. It can be solved be getting it serviced, would be worth getting the MPV (Minimum Pressure Valve) serviced at the same time.

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

Pressure doesn't build due to no air intake

Intermittently, our Ingersoll Rand compressor will run without shutting off due to it not getting up to pressure. When this happens, I've removed the intake air filter and no air is being drawn in. After shutting the compressor down and restarting it (sometimes several times - sometimes after letting it sit overnight) we'll hear a knocking sound several times and the pressure will begin to build until it reaches the correct PSI and then stops. We don't seem to have a leak because the pressure doesn't drop after it is up to pressure and shuts off. Wondering if this is an intake valve problem or possibly a solenoid valve issue?

Comments for Pressure doesn't build due to no air intake

Click here to add your own comments

Sep 03, 2012
Solenoid
by: Carls421

Hi, I would sy you have a problem with your Inlet Solenoid, check to see if you have voltage to the solenoid (should be on the airend coming from the controller) if not, then you could have a problem with the signal coming from the controller itself. If you have, then replace the solenoid, that should solve your problem

Click here to add your own comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.

ingersoll rand 175 maxxes out the pressure guage

by Jon Kinard
(spring, TX)

As soon as i turn on the machine it immediately maxxes out the pressure guage.

i have an ingersoll rand 175 tow behind that builds way too much pressure is there a regulator somewhere that could be busted?

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Ingersoll Rand Air Compressor Issues.