xas 375 jdc shuts down?

by Brian
(seattle WA USA)

xas 375 jdc - before it is warmed up enouph to load it shuts down


starting hard battery cranks starter for a while before it starts then before it is warmed up enouph to load it shuts down.Fluid levels are fine just had its 300 hour service

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

XAMS 286 CD not responding?

by Hany
(Nigeria)

XAMS 286 CD ( Engine not responding ) problem

Dear Sir,

We have Atlas Copco compressor XAMS 286 CD , the running hours : 444 , the engine CAT C6.6 ACERT
I need your help to solve my problem which is:
The compressor starts normally and we can load up to 2 bar, but if we increased it more it stops and it gives the below error:

Engine not responding

And I found that once I start without Load , the RPM of the engine is 1300 RPM and once I press the load button, the RPM become 1800 for about 10 seconds then it returns back to 1300 RPM , and when I start increasing the load ,the RPM is fixed to 1300 until I reach 2 bar .once I reach 2 bar ,the RPM goes down immediately .

1- I have checked the line of the fuel completely and changed the fuel and water separator filters but there is no problems inside it, then I run again but the same problem happened again.
2- I have removed the air filters and try to run without it , but still the same problem exists

I bring CAT in Nigeria and they check the engine by computer and the report show that it is very good

I have sent the compressor to Atlac Copco Nigeria but they couldn’t repair it .

So please I need your help

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

Atlas copco - engine turn switch not working?

atlas copco - engine turn switch

diesel 185 cfm with a John Deere 4024 engine
turn switch, starts, let go of switch, kills
____________________
I'm no expert on Atlas Copco compressors, and know even less about gas or diesel engines, but it sure sounds to me as though the switch may be the issue.

Other comments sure welcome.

Cheers,

Bill

Click here to post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.

Atlas xas 97 PRV lets go?

by Dave
(Urbana, ohio)

atlas xas 97 - it revs full throttle until the pop off blows

I start the compressor, it revs full throttle until the pop off blows,I checked the throttle actuator and it's not getting air to the throttle actuator to slow the engine.

Click here to read or post comments

Add your own question or comment. It's easy to do. How? Simply click here to return to Atlas Copco Compressor Issues.